Platform's Scope section malfunction
Incident Report for Fluid Attacks
Postmortem

Impact

An unknown number of users experienced issues when trying to access the Scope section of the Platform. The issue started on UTC-5 24-03-19 18:09 and was reactively discovered 14.8 hours (TTD) later by a customer who reported through our help desk [1] that the Scope section of some groups was not loading. The problem was resolved in 4.5 hours (TTF) resulting in a total impact of 19.4 hours (TTR) [2].

Cause

A required field was missing in the database backend. Although efforts were made to ensure the presence of this field in all records through a migration process, some records were found to be missing this field. This led to the Scope section of certain groups not displaying anything when accessed, as noted during API request analysis [3].

Solution

The team addressed the issue by retrieving the necessary data directly from a specific identifier instead of relying on a database attribute [4].

Conclusion

A data migration process was mishandled, highlighting the delicate nature of such operations when dealing with production data. To mitigate the risks associated with migrations, thorough peer reviews are essential. DATA_QUALITY < FAILED_MIGRATION

Posted Mar 21, 2024 - 08:56 GMT-05:00

Resolved
The incident has been resolved, and now the Scope section loads correctly.
Posted Mar 20, 2024 - 14:32 GMT-05:00
Identified
The platform fails to load the Scope section for some groups.
Posted Mar 20, 2024 - 10:16 GMT-05:00
This incident affected: Platform.