Error at trying to edit a git root on a group
Incident Report for Fluid Attacks
Postmortem

Impact

At least one root received an error message when trying to switch from Legacy VPN to Secure Access (UTC-05 23-05-25 15:00 to 23-09-18 17:05: 116.1 days -time to recover-). The incident was detected reactively (at UTC-5 23-09-15 10:33: 112.8 days -time to detect-) by a user who reported to one of our engagement managers [1] that when he tried to switch from Legacy VPN to Secure Access was shown this on-screen error There is an error :(.

Cause

The mutation in charge of making the change from Legacy VPN to Secure Access, identified by the name updateGitRoot, uses a field named organization_name which must exist in each of the vulnerabilities. The problem was that there were at least five vulnerabilities that did not have this field, due to a data population that was done through a migration in which it was not added [2].

Solution

A migration was executed to populate the organization_name field in all vulnerabilities where it was not present.

Conclusion

The problem was caused by a required field in the vulnerabilities, which did not exist due to an incorrect migration. DATA_QUALITY < FAILED_MIGRATION

Posted Sep 19, 2023 - 11:37 GMT-05:00

Resolved
The problem was solved and the roots can be edited without problems.
Posted Sep 18, 2023 - 17:54 GMT-05:00
Identified
An error with the message "There is an error :(" has been identified when trying to edit a git root.
Posted Sep 15, 2023 - 17:16 GMT-05:00
This incident affected: Platform.