Unable to add new group to an organization
Incident Report for Fluid Attacks
Postmortem

Impact

At least one user experienced issues creating new groups within an organization. The issue started on UTC-5 24-02-27 21:08 and was proactively discovered 23.7 days (TTD) later by a member of the product team who reported through our help desk [1] that they were experiencing issues when trying to create groups in organizations that had no previously created groups. The problem was resolved in 4.7 days (TTF) resulting in a total impact of 28.4 days (TTR) [2].

Cause

The returned set of components in the organization/groups empty page did not include the modal required for creating a new group, causing the New group button to malfunction [3].

Solution

It was necessary to remove the specific return for the case of an empty page and instead add the empty page component to the general return, where the group creation modal is included [4].

Conclusion

The lack of both unit tests and end-to-end tests prior to encountering the issue highlights a gap in the testing strategy. To address this, it is essential to incorporate a unit test [5] specifically tailored to this scenario, ensuring better coverage and early detection of similar issues in the future. INCOMPLETE_PERSPECTIVE < MISSING_TEST

Posted Mar 27, 2024 - 15:10 GMT-05:00

Resolved
The incident has been resolved, and now it is possible to add groups without any issue.
Posted Mar 27, 2024 - 10:09 GMT-05:00
Identified
Creation of a new group is not possible in organizations without existing groups.
Posted Mar 26, 2024 - 12:38 GMT-05:00
This incident affected: Platform.