Error when including URLs in the repository
Incident Report for Fluid Attacks
Postmortem

Impact

At least three organizations encountered an unexpected URL must include protocol (http:// or https://) or be a SSH URI exception when attempting to modify a root. The issue started on UTC-5 23-08-16 19:14 and was reactively discovered 14.8 hours (TTD) later by a user who reported [1] that he encountered the exception while trying to modify a field in an existing root. The problem was resolved in 5.7 hours (TTF) resulting in a total impact of 20.6 hours (TTR).

Cause

The problem was caused by a regex error in the utility responsible for validating the format of the root URL [2]. The regex did not correctly validate the URLs, leading to the exception being thrown.

Solution

The regex responsible for validating the roots URL was corrected [3].

Conclusion

Validation was not tested with all possible URL formats for roots. MISSING_TEST

Posted Sep 27, 2023 - 23:48 GMT-05:00

Resolved
The problem was solved and now git roots can be edited without problems.
Posted Aug 17, 2023 - 19:19 GMT-05:00
Identified
When a user tries to edit a git root that is associated with an SSH type URL, the platform does not allow to perform the needed change/edition, showing an error message.
Posted Aug 17, 2023 - 14:12 GMT-05:00
This incident affected: Web.