Problem at listing groups for some organizations
Incident Report for Fluid Attacks
Postmortem

Impact

At least three organizations were unable to list the groups in the groups' section (UTC-05 23-09-15 13:02 to 23-09-18 12:37: 3 days -time to recover-). The incident was detected reactively (at UTC-5 23-09-18 10:23: 2.9 days -time to detect-) by a user, who reported through our help desk [1] that when entering the list of his organizations they did not load.

Cause

The problem was generated by a merge request [2] that was made with the objective of displaying real-time indicators, which works by making individual requests to the database, which degraded the performance and generated 504: Timeout error errors.

Solution

The merge request that caused the problem was reverted [3] and the groups were subsequently verified to load correctly.

Conclusion

As it was a performance issue it could not be tested before it occurred in production with all the data that goes with it. IMPOSSIBLE_TO_TEST

Posted Sep 18, 2023 - 14:37 GMT-05:00

Resolved
The problem was solved and the groups are now listed typically.
Posted Sep 18, 2023 - 18:32 GMT-05:00
Identified
Cases have been identified in which the groups of certain organizations are not listed.
Posted Sep 18, 2023 - 10:23 GMT-05:00
This incident affected: Web.