Atypical increase of authors
Incident Report for Fluid Attacks
Postmortem

Impact

The author's invoicing was incorrectly calculated for three clients (at UTC-05 23-07-07 16:52 to 23-08-08 12:52: 1 month -time to recover-). The incident was discovered reactively (at UTC-5 23-07-29 19:00: 22.1 days -time to detect-) by one of the clients, who noticed that his invoicing was informing him that he was being charged for authors, which should not have been billed, and reported it through the engagement manager.

Cause

The engineering team was performing a refactoring in order to improve the accuracy in the calculation of authors [1], part of this work was to migrate the fa-hashes that identify the unique authors from the old form to the improved form, this step took longer than expected and at the time of calculating authors had for the same authors fa-hashes with both the old and improved form, so they were double counted.

Solution

Fluid Attacks technical representatives met with affected customers to correct the author count by removing all duplicates.

Conclusion

A delay in the migration caused a calculation error in the fa-hash field, which should be a unique field, so every fa-hash that looked different was counted as an increment. FAILED_PEER_REVIEW

Posted Sep 18, 2023 - 19:58 GMT-05:00

Resolved
The calculation of authors was corrected and is now performed correctly.
Posted Aug 08, 2023 - 12:52 GMT-05:00
Identified
Cases were identified in which the authors were incorrectly counted.
Posted Jul 29, 2023 - 19:00 GMT-05:00
This incident affected: Platform.