Error adding roots via OAuth
Incident Report for Fluid Attacks
Postmortem

Impact

An unknown number of users experienced issues when adding roots via OAuth. The issue started on UTC-5 24-04-29 10:12 and was reactively discovered 5.7 hours (TTD) later by a customer who reported through our help desk [1] difficulties while attempting to add roots on the platform using OAuth. The problem was resolved in 18 hours (TTF) resulting in a total impact of 23.7 hours (TTR) [2].

Cause

Recent modifications were made to the auto-enrollment section, adding components from a new design. However, differences in implementation between the radio button and checkbox component were overlooked. This issue specially affected the OAuth form for adding a new root, with the button in the form being disabled [3].

Solution

It was necessary to update the settings of the checkbox and radio button components. This change enabled the necessary form validations and activated the button for submission [4].

Conclusion

Lack of tests and ongoing component changes led to the issue. To prevent similar incidents, tests will be implemented [5]. INCOMPLETE_PERSPECTIVE < MISSING_TEST

Posted Apr 30, 2024 - 12:05 GMT-05:00

Resolved
The incident has been resolved, and now the addition of git roots via OAuth works correctly.
Posted Apr 30, 2024 - 10:44 GMT-05:00
Update
The cause of the incident has been identified, and a solution is being implemented.
Posted Apr 30, 2024 - 09:56 GMT-05:00
Identified
Some problems were noticed when trying to add git roots via OAuth.
Posted Apr 30, 2024 - 09:41 GMT-05:00
This incident affected: Platform.