Issues when adding exclusion on git roots
Incident Report for Fluid Attacks
Postmortem

Impact

At least one user experienced issues while attempting to add exclusions on git roots in the platform. The issue started on UTC-5 23-11-03 11:28 and was reactively discovered 3.7 months (TTD) later by a customer, who reported through our help desk, that he encountered an on-screen error message There is an error :( when trying to exclude folders in a repository. The problem was resolved in 4.8 days (TTF) resulting in a total impact of 3.9 months (TTR) [1][2].

Cause

An incorrect implementation of file exclusion process led to the issue. Recent changes aimed at fixing another error involving the backslash character inadvertently caused the exclusion process to misinterpret file formats [3].

Solution

We modified the validation process to ensure the information is formatted correctly. Specifically, we cleaned up the exclusions to ensure they are received in the correct regular expression format [4].

Conclusion

The absence of functional tests allowed this issue to reach production. To prevent similar incidents in the future, we plan to implement additional tests and validate the format using a more straightforward method to match Git’s behavior. Therefore, an issue was created to implement such tests [5]. INCOMPLETE_PERSPECTIVE < MISSING_TEST

Posted Feb 29, 2024 - 14:48 GMT-05:00

Resolved
The incident has been resolved, and now the functionality to add exclusion on git roots is working correctly.
Posted Feb 28, 2024 - 14:03 GMT-05:00
Identified
The functionality to add exclusions on git roots is not working as expected.
Posted Feb 28, 2024 - 10:48 GMT-05:00
This incident affected: Platform.