Difficulties in multiple platform sections
Incident Report for Fluid Attacks
Postmortem

Impact

An unknown number of users experienced difficulties while navigating the platform as information was not being listed in views such as Groups, Vulnerabilities, Consulting, and others. The issue started on UTC-5 24-03-18 16:39 and was reactively discovered 43.2 minutes (TTD) later by a customer who reported through our help desk [1] that the Groups view was not loading correctly. The problem was resolved in 2.4 hours (TTF) resulting in a total impact of 3.1 hours (TTR).

Cause

An incompatible change in the API occurred due to the renaming of plans from Machine to Essential and Squad to Advance. This change required adjustments to the corresponding functions in the back-end [2].

Solution

The problematic commit was reverted to address the issue [3].

Conclusion

An API incompatibility triggered the issue, revealing shortcomings in the testing environment’s ability to evaluate such scenarios. To address similar incidents, step-by-step guide will be created to ensure seamless transitions when renaming components, enhancing testing procedures for future changes [4]. INCOMPLETE_PERSPECTIVE < IMPOSIBLE_TO_TEST

Posted Mar 19, 2024 - 09:16 GMT-05:00

Resolved
The incident has been resolved, and the platform is now operating smoothly.
Posted Mar 18, 2024 - 18:04 GMT-05:00
Identified
Sections such as Groups, Vulnerabilities, Consulting are currently unavailable.
Posted Mar 18, 2024 - 17:30 GMT-05:00
This incident affected: Platform.