Inconsistencies in target of evaluation lines of code
Incident Report for Fluid Attacks
Postmortem

Impact

An unknown number of users experienced inconsistencies with the ToE lines within progress reports and the scheduled cloning. The issue started on UTC-5 24-01-18 11:20 and was proactively discovered 3.8 days (TTD) later by analysts who noticed the inconsistency in the reported number of lines of code. The problem was resolved in 2.1 days (TTF) resulting in a total impact of 5.9 days (TTR) [1][2].

Cause

We were implementing a migration with the aim of resetting inconsistencies in the Attacked lines. During this migration period, there were some disparities and inconsistencies in the data [3].

Solution

When the migration was completed, all inconsistencies were resolved [4].

Conclusion

The incident originated from intentional and necessary modifications to the production database during a migration. To prevent similar occurrences, there is a call to enhance communication protocols, specially for significant migrations, is emphasized. This underscores the relevance of notifying group chats before executing impactful migrations. FAILED_MIGRATION

Posted Jan 25, 2024 - 14:48 GMT-05:00

Resolved
The incident has been resolved, and now the ToE lines are being reported accurately.
Posted Jan 24, 2024 - 14:00 GMT-05:00
Identified
Anomalies detected in analysts' progress reports and the 'Attacked lines' platform column, specifically concerning the amount of Target of Evaluation lines of code.
Posted Jan 23, 2024 - 15:04 GMT-05:00
This incident affected: Platform.