Difficulties when adding new member by external user
Incident Report for Fluid Attacks
Postmortem

Impact

At least one external user experienced issues when being the sole member at the group or organization level, while attempting to add new members. The issue started on UTC-5 24-03-01 18:01 and was reactively discovered 9.8 days (TTD) later by one of the clients, who noticed that when using the functionality to invite new members, they were redirected to a new window where the member addition modal failed to open, and reported it through one of our engagement managers. The problem was resolved in 23.7 hours (TTF) resulting in a total impact of 10.8 days (TTR) [1][2].

Cause

An error in the Empty state component, triggered when no data is available on the platform, such as the absence of active members, caused the issue. Although the component’s button should either open an internal modal or redirect to a webpage, a programming error consistently redirected users to an external link, even when the URL was undefined, resulting in a blank browser tab [3].

Solution

The team modified the link component to prevent opening a new window if the URL is undefined [4].

Conclusion

The component lacked an associated unit test, which contributed to the oversight of the button click action before deployment to production. To prevent similar issues in the future, unit tests have been implemented for the component, ensuring thorough verification of both redirection to external URLs and internal platform actions [5]. INCOMPLETE_PERSPECTIVE < MISSING_TEST

Posted Mar 12, 2024 - 16:48 GMT-05:00

Resolved
The incident has been resolved, and now the modal for adding new members works as expected.
Posted Mar 12, 2024 - 15:29 GMT-05:00
Identified
When an external user is the sole member of a group or organization, faces an issue when adding new members; the platform opens a new browser window instead of the modal to invite a member.
Workaround: The user should return to the main page where the action was initially executed to proceed with the request.
Posted Mar 12, 2024 - 14:24 GMT-05:00
This incident affected: Platform.