Error adding secrets related to URL roots
Incident Report for Fluid Attacks
Postmortem

Impact

At least one user experienced issues when trying to add a new secret related to a URL root. The issue started on UTC-5 24-04-23 12:20 and was proactively discovered 14.9 days (TTD) later by one of our engagement managers who reported through our help desk [1] that an error message There is an error :( appears when trying to add a secret in a group with Black service. The problem was resolved in 5 hours (TTF) resulting in a total impact of 15.1 days (TTR) [2].

Cause

The validation process for secrets overlooked the existence of multiple Root types beyond GitRoot. Consequently, when verifying the root type for secrets in Black plan, it was identified as URLRoot instead of GitRoot, causing the validation to fail [3].

Solution

All different root types were included for validation [4].

Conclusion

The lack of awareness of the flow variation in the Black plan underscored the necessity of incorporating tests for the secrets flow in this plan to ensure comprehensive coverage across different plan types. As a result, tests will be added to validate the secrets flow, aligning with existing testing practices for other plan types [5]. INCOMPLETE_PERSPECTIVE < MISSING_TEST

Posted May 08, 2024 - 17:22 GMT-05:00

Resolved
The incident has been resolved, and users can now add secrets normally.
Posted May 08, 2024 - 15:43 GMT-05:00
Identified
Some problems were noticed when trying to add secrets to URL roots in groups with Black service.
Posted May 08, 2024 - 13:39 GMT-05:00
This incident affected: Platform.