Issues editing git roots
Incident Report for Fluid Attacks
Postmortem

Impact

At least two organizations experienced issues while attempting to edit a git root. The issue started on UTC-5 24-03-27 19:31 and was reactively discovered 4.5 days (TTD) later by a customer who reported through our help desk [1] that when trying to add exclusions to a git root, they encountered the error message There is an error :(. The problem was resolved in 3.6 hours (TTF) resulting in a total impact of 4.7 days (TTR) [2].

Cause

A new field was added to define the criticality of a Git Root. However, when implementing the form, a default value was not correctly added for this field, causing form submission errors when trying to edit or add a Git Root without modifying the criticality value [3].

Solution

The team added the default value just before submitting the form to address the issue [4].

Conclusion

The lack of tests contributed to the oversight, highlighting the importance of manual testing in addition to automated tests. While unit tests and functional tests were in place, they did not catch the issue of adding a new field without updating the default form values. This incident underscores the need for a structured approach to form handling and testing, as well as ongoing refactoring efforts to maintain code quality. INCOMPLETE_PERSPECTIVE < MISSING_TEST

Posted Apr 02, 2024 - 16:02 GMT-05:00

Resolved
The incident has been resolved, and now the functionality to edit git roots is working correctly.
Posted Apr 01, 2024 - 15:55 GMT-05:00
Identified
The functionality to edit git roots is not working as expected.
Posted Apr 01, 2024 - 11:08 GMT-05:00
This incident affected: Platform.