Error 404 when accessing the platform.
Incident Report for Fluid Attacks
Postmortem

Impact

At least one platform user encountered a blank screen when entering the platform. The issue started on UTC-5 23-09-04 13:25 and was reactively discovered 2.1 hours (TTD) later by one user who experienced a white screen when entering the platform and reported it [1]. The problem was resolved in 57.6 minutes (TTF) resulting in a total impact of 3.1 hours (TTR).

Cause

The merge request [2] activated a configuration to enhance the platform's performance. Still, we failed to notice that the Cloudflare headers didn't have the required script [3] configured, resulting in a Cors Origin violation.

Solution

The engineering team disabled [4] the previously mentioned configuration to mitigate mishaps while the configuration is added appropriately.

Conclusion

Tests were needed to inform us of the problem before it reached production. There is already an issue [5] to add these tests. MISSING_TEST

Posted Sep 14, 2023 - 20:14 GMT-05:00

Resolved
Scripts not configured in the CORS policy were used.
Posted Sep 04, 2023 - 16:31 GMT-05:00
Identified
We encountered 404 errors that prevented our platform from loading correctly.
Posted Sep 04, 2023 - 15:55 GMT-05:00
This incident affected: Platform.