Comment text boxes malfunction
Incident Report for Fluid Attacks
Postmortem

Impact

An unknown number of users experienced issues when typing in the comment text boxes on the Consulting and Observations views on the platform. The issue started on UTC-5 24-03-08 13:14 and was proactively discovered 5 days (TTD) later by a staff member who reported through our help desk [1] that the comment field in Consulting was experiencing issues when attempting to write, leading to inconsistency in the message being written. The problem was resolved in 19.9 hours (TTF) resulting in a total impact of 5.8 days (TTR) [2].

Cause

Attempting to change the current TextArea to the TextArea of the new preview feature components without adapting the entire form led to the issue [3].

Solution

It was necessary to revert to the previous version of the fields [4].

Conclusion

The lack of testing for error scenarios in the comment field led to the issue. To prevent similar incidents, more thorough testing has been implemented for basic user flows, and there will be greater caution when implementing changes to new components to avoid unexpected behavior [5]. INCOMPLETE_PERSPECTIVE < MISSING_TEST

Posted Mar 15, 2024 - 09:27 GMT-05:00

Resolved
The incident has been resolved, and the comment text boxes are now working properly.
Posted Mar 14, 2024 - 13:14 GMT-05:00
Identified
The comment text boxes in both the Consulting and Observations sections are experiencing issues when attempting to add, edit, or delete text.
Posted Mar 14, 2024 - 09:10 GMT-05:00
This incident affected: Platform.