A blank screen is returned when entering edit environments
Incident Report for Fluid Attacks
Postmortem

Impact

At least two organizations received a blank screen when trying to add/edit environments in the Roots editing panel. (at UTC-05 23-09-06 13:21 to 23-09-08 17:58 2.2 days -time to recover-). The incident was detected reactively (at UTC-5 23-09-08 14:26: 2 days -time to detect-) by a user who reported through our helpdesk [1] that he tried to add an environment to a root and the platform returned a white screen.

Cause

To persist the sorting preferences, the hook useStoredState was used. To work properly, this hook requires the use of the function useState, but it was never called in the code [2], causing the value to not be updated correctly. This resulted in making the preferences set in a table be set globally instead of separated by each table, so, when switching between tables, instructions were passed for attributes that existed in the first table but not in the second. This generated an error that caused the platform to return a white screen.

Solution

The permanence of the sorting was disabled [3], this way the sorting options are not being saved and the cracking is prevented from occurring. This is a temporary workaround that eliminates the blank screen bug, however, the engineering team is working on re-enabling the permanence of the sorting options.

Conclusion

This incident had the same problem as this other incident, so both were resolved at the same time.

The platform had tests that confirmed the correct sorting in the tables, however, these did not take into account a sorting persistence functionality that did not previously exist, and for which no tests were added or effectively tested manually when added. MISSING_TEST

Posted Sep 15, 2023 - 13:35 GMT-05:00

Resolved
The engineering team has analyzed the case and it has been determined that it has been solved and you can edit the environments without any inconvenience.
Posted Sep 08, 2023 - 17:58 GMT-05:00
Identified
Situations have been observed in which a blank screen is generated when trying to modify the environments in the roots panel.
Posted Sep 08, 2023 - 14:26 GMT-05:00
This incident affected: Platform.