Verification code delivery issues
Incident Report for Fluid Attacks
Postmortem

Impact

An unknown number of users experienced issues accessing the platform as they were not receiving the verification code in their emails. The issue was reactively discovered by a customer who reported the problem to one of our engagement managers [1] indicating that they could not access the platform. The problem was resolved in 1.1 days (TTF) [2].

Cause

We use SendGrid to send emails to our users. Each email includes a link for globally unsubscribing from all SendGrid emails. Some email providers have automated programs that click on all links in emails, leading to unintended global unsubscribes for our users.

Solution

A new functionality was implemented requiring users to confirm their intention to unsubscribe. Users are now redirected to an endpoint where they must explicitly confirm their desire to unsubscribe from our emails [3].

Conclusion

To address this, a new functionality was created requiring users to confirm their intention to unsubscribe, preventing accidental opt-outs. THIRD_PARTY_ERROR

Posted Jun 04, 2024 - 18:48 GMT-05:00

Resolved
The incident has been resolved, and now users are no longer being unsubscribed involuntarily.
Posted May 31, 2024 - 18:37 GMT-05:00
Update
This issue has been traced to the email provider inadvertently unsubscribing users from our service. We are actively working on a solution.
Posted May 30, 2024 - 14:04 GMT-05:00
Identified
Problems have been detected with some users trying to access the platform as they are not receiving verification codes.
Posted May 30, 2024 - 12:02 GMT-05:00
This incident affected: Mailing.