Search bar shows wrong results
Incident Report for Fluid Attacks
Postmortem

Impact

An unknown number of platform users received unexpected results when using the search bar in the vulnerability view (UTC-05 23-01-16 17:12 to 23-08-10 12:53: 6.8 months -time to recover-). The incident was discovered proactively (at UTC-5 23-07-13 19:12: 5.9 months -time to detect-) by one of our engagement managers while doing a search in the vulnerability view [1].

Cause

The utilization of the globalFilter component [2] proved insufficient for our needs as it operates on a global scale and does not offer the targeted data filtering required for the table rows being displayed.

Solution

We've implemented modifications to both the search bar component [3][4] and the associated table to ensure the search functionality works correctly.

Conclusion

The search bar was built without sufficient planning and it had not been agreed exactly what results it should deliver. LACK_OF_PLANING

Posted Sep 18, 2023 - 19:33 GMT-05:00

Resolved
The problem has been resolved and the search bar is working properly.
Posted Aug 10, 2023 - 12:53 GMT-05:00
Identified
It has been identified that using the search bar yields inconsistent results.
Posted Jul 13, 2023 - 19:12 GMT-05:00
This incident affected: Web.