Docs unavailability
Incident Report for Fluid Attacks
Postmortem

Impact

An unknown number of users found the Fluid Attacks' official documentation unavailable (at UTC-5 23-11-14 12:27 to 23-11-14 15:09 | Time to recover was 1.2 hours). The incident was discovered proactively (at UTC-5 23-11-14 14:04 | Time to detect was 1.6 hours) by one of our monitoring tools and staff members, indicating the outage of this component.

Cause

During a Proof of Concept aimed to solve an issue [1], certain modifications inadvertently omitted crucial elements necessary for the documentation's functionality on the internet [2], leading to downtime.

Solution

The missing elements were included, and a new deployment of the documentation was executed [3], thus restoring its availability.

Conclusion

The environment the developers use to test the changes does not consider these important elements in question for its functionality, making it difficult to catch these errors before the changes go to production. The team is working to add tests to capture these problems before getting to the real environment. MISSING_TEST

Posted Nov 14, 2023 - 18:21 GMT-05:00

Resolved
The incident was resolved and docs.fluidattacks.com is now working normally.
Posted Nov 14, 2023 - 16:11 GMT-05:00
Identified
docs.fluidattacks.com is experiencing a period of unavailability.
Posted Nov 14, 2023 - 14:20 GMT-05:00
This incident affected: Docs.