A white screen is returned when trying to create a new event
Incident Report for Fluid Attacks
Postmortem

Impact

At least one user got a white screen when trying to create a new event in the events section (UTC-05 23-09-05 09:13 to 23-09-05 15:29: 6.2 hours -time to recover-). The incident was found reactively (at UTC-5 23-09-05 12:01: 2.8 hours -time to detect-) by a user who got a blank screen while trying to create an event and reported it via our help team [1].

Cause

We are in the process of transitioning from MaterialUI to Styled-Components. As part of this transition, one key task is to implement a Styled-Components configuration known as theming [2]. This theming configuration essentially serves as a wrapper that encompasses the entire application, enabling the provision of styles.

However, the problem was when applying this theming wrapper [3]. MaterialUI also employs a similar wrapper [4], and it mistakenly interpreted our theming configuration as its own. Consequently, the app threw errors such as "cannot read property 'value' of undefined".

Solution

The component that caused the problem was encapsulated in a MaterialUI configuration where the Styled-Component is not used yet, thus there are no conflicts between the two libraries [5].

Conclusion

The existence of two similar components in two frameworks used by the platform generated conflicts between the configurations of both components, this was not detected before going to production because there were no E2E tests. An issue was created to handle the issue more efficiently and add the respective tests [6]. MISSING-TEST

Posted Sep 14, 2023 - 16:11 GMT-05:00

Resolved
The team has performed a fix and now events can be created without problems.
Posted Sep 05, 2023 - 15:39 GMT-05:00
Identified
It has been observed that a blank screen is generated when trying to create a new event.
Posted Sep 05, 2023 - 12:44 GMT-05:00
This incident affected: Platform.