Issues with the AGENT while making queries to the API
Incident Report for Fluid Attacks
Postmortem

Impact

At least one internal user noticed issues with automated tasks and monitoring alerts. The issue started on UTC-5 24-01-24 12:08 and was proactively discovered 43.2 minutes (TTD) later by one of our monitoring tools and staff members who signaled the failure. The problem was resolved in 1.4 hours (TTF) resulting in a total impact of 2.1 hours (TTR) [1].

Cause

The AGENT experienced failures due to an error in the query used to communicate with the API. This arose when changing the data type of an attribute in the vulnerabilities in the database, as part of resolving a specific issue related to the presence of unexpected information in certain database fields, leading to a failure in the new data typing [2].

Solution

The team implemented a new modification, taking into account formatting error and addressing the identified issue during the incident [3].

Conclusion

Inconsistencies were found in the database data for very old vulnerabilities, whose information was not included in the test cases. To prevent similar situations in the future, measures will be implemented, such as updating test data and improving database typing [4]. DATA_QUALITY

Posted Jan 25, 2024 - 17:01 GMT-05:00

Resolved
The incident has been resolved, and the AGENT is working correctly.
Posted Jan 25, 2024 - 12:58 GMT-05:00
Identified
The AGENT experienced failures due to an error in the query it uses to communicate with the API.
Click for details: https://availability.fluidattacks.com
Posted Jan 24, 2024 - 12:41 GMT-05:00
This incident affected: Agent.