A white screen is returned when reordering columns
Incident Report for Fluid Attacks
Postmortem

Impact

An unknown number of users encountered a blank screen after rearranging elements in various tables and attempting to access some of those elements. The issue started on UTC-5 23-09-06 13:21 and was proactively discovered 1.9 days (TTD) later by one of our developers while using the platform. He experienced a blank screen when rearranging elements in the vulnerability table and then attempting to access one of the vulnerabilities and reported it internally to create the respective issue [1]. The problem was resolved in 6.7 hours (TTF) resulting in a total impact of 2.2 days (TTR).

Cause

To persist sorting preferences, the hook useStoredState was utilized. For proper functionality, this hook requires the use of the useState function, which was inadvertently omitted from the code [2]. As a result, the value was updated correctly, causing preferences set in one table to be applied globally instead of separately for each table. Consequently, when switching between tables, instructions were passed for attributes that existed in the first table but not in the second, leading to an error that triggered the blank screen.

Solution

The persistence of sorting preferences was disabled [3], preventing the saving of sorting options and mitigating the issue. This serves a temporary workaround that eliminate the blank screen bug. However, the engineering team is actively working on re-enabling sorting persistence.

Conclusion

While the platform had tests confirming correct sorting in tables, these tests did not account for a sorting persistence feature that was newly introduced. Consequently, no tests were added for this feature, nor were they effectively tested manually upon implementation. MISSING_TEST

Posted Sep 14, 2023 - 15:32 GMT-05:00

Resolved
The team has performed a fix and it is evident that the tables can now be reordered without any problems.
Posted Sep 08, 2023 - 17:59 GMT-05:00
Identified
It has been detected that a blank screen appears when trying to change the order of the columns.
Posted Sep 07, 2023 - 10:58 GMT-05:00
This incident affected: Platform.