Analytics charts filtering issues
Incident Report for Fluid Attacks
Postmortem

Impact

An unknown number of users experienced issues with the filtering options of the charts in the analytics sections. The issue started on UTC-5 24-03-19 16:46 and was reactively discovered 20.6 days (TTD) later by a customer who reported through our help desk [1] difficulties with selecting filters on the charts. The problem was resolved in 6.9 hours (TTF) resulting in a total impact of 20.9 days (TTR) [2].

Cause

Replacing a component with its newer version caused the filter list to appear behind the chart in the analytics tab, rendering it inaccessible for selection [3].

Solution

It was necessary to adjust the display settings to ensure that the filter list appears above the chart when hovering over it [4].

Conclusion

The absence of end-to-end tests in the analytics tab resulted in the issue occurring. Moving forward, tests will be implemented to ensure the stability and functionality of chart features [5]. INCOMPLETE_PERSPECTIVE < MISSING_TEST

Posted Apr 09, 2024 - 18:18 GMT-05:00

Resolved
The incident has been resolved, and now the filtering options in the analytics charts are working as expected.
Posted Apr 09, 2024 - 16:40 GMT-05:00
Identified
The filtering options in the analytics charts are not functioning properly.
Posted Apr 09, 2024 - 11:35 GMT-05:00
This incident affected: Platform.