Docs unavailability
Incident Report for Fluid Attacks
Postmortem

Impact

An unknown number of users encountered the Fluid Attacks' official documentation unavailable. The issue started on UTC-5 24-04-09 09:01 and was proactively discovered 28.8 minutes (TTD) later by one of our monitoring tools and staff members, indicating a disruption in this component. The problem was resolved in 14.4 minutes (TTF) resulting in a total impact of 43.2 minutes (TTR).

Cause

An error in handling URL redirections led to Cloudflare encountering an issue when deploying the documentation infrastructure due to a change in how redirections were managed [1].

Solution

The commit that introduced the issue was reverted [2].

Conclusion

Testing this issue locally is not feasible as it involves infrastructure changes, requiring a full deployment to production to capture the error. To prevent similar issues in the future, a tool will be created to automatically check for errors in the infrastructure’s JavaScript files [3]. For now, the best approach is to have someone review the changes before they’re approved. INFRASTRUCTURE_ERROR < IMPOSSIBLE_TO_TEST

Posted Apr 09, 2024 - 16:17 GMT-05:00

Resolved
The incident has been resolved, and now docs.fluidattacks.com is working normally.
Posted Apr 09, 2024 - 10:10 GMT-05:00
Identified
docs.fluidattacks.com is experiencing a period of unavailability. Click for details: https://availability.fluidattacks.com
Posted Apr 09, 2024 - 09:37 GMT-05:00
This incident affected: Docs.